summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-10-25 14:00:33 +0200
committerLudovic Courtès <ludo@gnu.org>2016-10-25 14:00:33 +0200
commit301d73f68c791d659f752595ae32db015be0216a (patch)
treec629dd877f969879f4c05674ff5bbe733c9492a4 /configure.ac
parent8ce84bf1f5705f5280e8bf8f150ec2e859b045ee (diff)
downloadguix-301d73f68c791d659f752595ae32db015be0216a.tar.gz
build: 'guilemoduledir' honors $GUILE_EFFECTIVE_VERSION.
* configure.ac: Define 'guilemoduledir' as a function of $GUILE_EFFECTIVE_VERSION.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3b33f851e7..34f1323792 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,9 +21,6 @@ AC_USE_SYSTEM_EXTENSIONS
AM_GNU_GETTEXT([external])
AM_GNU_GETTEXT_VERSION([0.18.1])
-guilemoduledir="${datarootdir}/guile/site/2.0"
-AC_SUBST([guilemoduledir])
-
GUIX_SYSTEM_TYPE
GUIX_ASSERT_SUPPORTED_SYSTEM
@@ -77,7 +74,7 @@ m4_pattern_forbid([GUILE_MODULE_AVAILABLE])
m4_pattern_forbid([^GUILE_P$])
dnl Search for 'guile' and 'guild'. Prefer 2.0 until the 2.2 upgrade is
-dnl complete.
+dnl complete. This macro defines 'GUILE_EFFECTIVE_VERSION'.
GUILE_PKG([2.0 2.2])
GUILE_PROGS
if test "x$GUILD" = "x"; then
@@ -90,6 +87,10 @@ else
AC_MSG_WARN([Guile $GUILE_EFFECTIVE_VERSION is not fully supported!])
fi
+dnl Installation directory for .scm and .go files.
+guilemoduledir="${datarootdir}/guile/site/$GUILE_EFFECTIVE_VERSION"
+AC_SUBST([guilemoduledir])
+
dnl guile-json is used for the PyPI package importer
GUILE_MODULE_AVAILABLE([have_guile_json], [(json)])
AM_CONDITIONAL([HAVE_GUILE_JSON], [test "x$have_guile_json" = "xyes"])